Results 1 to 19 of 19

Internet Speed Issues with Linksys WAG54 G2 on BSNL Broadband

  1. #1
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default Internet Speed Issues with Linksys WAG54 G2 on BSNL Broadband

    Hi,
    I have a BSNL broadband connection with 256 to 2 MBps line (Home 500CP) in Hyderabad, Andhra Pradesh. Recently, I purchased a Linksys WAG54 G2 ADSL+ Wireless router and configured it using the CD provided but noticed that the Internet speed was very slow. I contacted the Linksys technical support for help and they did try to reconfigure the gateway multiple times but the speed issue was not resolved. They also reflashed the firmware. They even replaced my gateway but the problem still persists. Finally they told me that it could be some settings from BSNL which are not matching with the router settings. Can someone help me by providing their router settings if your router is working fine with BSNL connection and no speed issues so that I can set the same on my router and check? Your help in this regard will be greatly appreciated. Thanks in advane.

    Regards
    Venkat

  2. #2
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    USE OPEN dns 208.67.220.220
    AND 208.67.222.222
    Test speed at speedtest.net mumbai /sydney server.
    and give links here.

    If you have BSNL modem compare speeds with Linksy's .

  3. #3
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Thanks very much for a quick response. I am sorry I didn't understand what you meant by Use Open dns, could you please clarify?

  4. #4
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    Start Network LOcal Area network
    Properties
    TCP/IP
    Properties
    enter in DNS column
    208.67.220.220
    and 208.67.222.222
    ( make a note of previous entries !)
    You can click Advanced and enter them there.
    Save Apply.


    Para two:
    http://img90.imageshack.us/img90/8943/linksysbm7.jpg

    If page appears same enter dns here also.
    to be on safe side enter 3rd entry BSNL dns !
    Check MTU is 1492.

    Save reboot. wait for one or two minutes.
    Feedback please.

  5. #5
    Junior Member Karamjeet's Avatar
    Join Date
    Aug 2008
    Posts
    80

    Wink Use OpenDNS

    1. Select Control Panel from the Start menu.
    2. Click Network Connections from the Control Panel choices.
    3. Choose your connection from the Network Connections window.
    4. Click Properties button.
    5. Select Internet Protocol (TCP/IP) and click Properties.
    6. Click the radio button Use the following DNS server addresses and type in OpenDNS addresses in the Preferred DNS server and Alternate DNS server fields.

  6. #6
    meetdilip
    Guest

    Default


  7. #7

  8. #8
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Thanks for the responses so far. Tested the Internet speed as suggested with speedtest.net, Mumbai server and following are the results.

    Linksys WAG54 G2 Router Results:



    Huawei Quidway WA1003A from BSNL Results:



    I was not allowed to post the URLs hence trimmed. Await further instructions. Your help is greatly appreciated
    Last edited by just4kix; 22nd May 2009 at 11:43 AM.

  9. #9
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    @mvenkat_2000

    1.No problem. Easy to copy and paste in the address bar.

    2. Confirm Linksy's Modem/router was used in WIFI mode.

    ISP BSNL Server Mumbai
    WAG54 G2 D/L 1.04Mbps U/L .09Mbps 96ms
    WA1003A D/L 1.70Mbps U/L .35Mbps 86ms
    3. If confident, download TCP/IP optimizer from
    speedguide.net.
    (a) Save as back up present settings.
    (b) Try default values suggested.
    (c) Try recommended values.
    in this application.
    The speed bar : available max speed say 2 Mbps.


    3. Please Confirm Linksy's modem/router is stable now.
    for reference:
    http://img84.imageshack.us/img84/4702/1234zn8.jpg
    Last edited by essbebe; 9th May 2009 at 07:49 AM.

  10. #10
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Forgot to mention... the speed test was done on Wifi in both the routers.

    What is TCP/IP optimizer? do i need to download in all the laptops i use? Also, there were links showing the linksys router settings page in your first post, am i supposed to use the same setting in my router as well. Bit confused could you please clarify what are the steps that i need to follow now. Sorry about my ignorance.. am not that tech savy so sometimes cant follow your tech language :-(. Sorry for the inconvenience and thanks so much for your guidance.

  11. #11
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    [quote]Forgot to mention... the speed test was done on Wifi in both the routers[/quote.]
    Noted.

    TCP/IP optimizer : try in one lap top.
    1. Make speed tests BEFORE and AFTER using this application If any improvement try in others.
    Yes in all laptops this has to be installed. .

    2. Please mention how many desktops/laptops are being used.

    3. As per first post, I feel Speed problem with Linksys'
    wifi modem has been solved to a certain extent.
    Confirm .

    4. Not many changes are required ,
    and will be done later if required. will ask for data.
    Do not change any settings now.
    Screen shots , I usually give for my reference/reading/study & future reference, if this thread is accessed.








    .

  12. #12
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    1. I downloaded the TCP/IP Optmizer, copied to my desktop and ran it. After running it, a TCP Optimizer window opened. in that window, I did a Backup Current Settings and then selected the Radio Button Optimal Settings and clicked on Apply Changes Button and allowed to reboot. Is that procedure right?

    Below are the results of the speed test taken on 9th May 2009 (8.00pm to 9.30pm)

    Before TCP Optimizer:
    Linksys WAG54 G2 Router Results:

    speedtest.net/result/469922970.png
    D/L 0.52 U/L 0.13 ping 92ms

    Huawei Quidway WA1003A from BSNL Results:

    speedtest.net/result/469927491.png
    D/L 1.69 U/L 0.24 ping 85ms


    After TCP Optimizer:
    Linksys WAG54 G2 Router Results:

    speedtest.net/result/469949733.png
    D/L 0.39 U/L 0.06 ping 205ms

    Huawei Quidway WA1003A from BSNL Results:

    speedtest.net/result/469943385.png
    D/L 1.62 U/L 0.24 ping 162ms

    2. I have 2 work laptops and 1 personal laptop and an iPhone
    most of the times it is only one laptop which is in use.. very rarely two laptops will be used together.

    3. I dont think the speed issues are resolved with my linksys router if u see the above results when compared to my bsnl router. the earlier test results were taken during midnight between 1.00-2.00 am.

    4. how do i uninstall TCP optimizer if required?

    Await further instructions

  13. #13
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    4. how do i uninstall TCP optimizer if required?
    No need. you can use it whenever needed. wait please.
    2.
    Linksys' router: speed seems to have reduced.

    http://img84.imageshack.us/img84/4702/1234zn8.jpg
    Post the speed shown in above page.

  14. #14
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Downstream Rate : 2046 Kbps
    Upstream Rate : 512 Kbps

    Hi, any update???? Sorry for not being able to reply immediately as I have been travelling during the weekend.
    Last edited by mvenkat_2000; 12th May 2009 at 03:47 PM. Reason: Automerged Doublepost

  15. #15
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    seems Normal now.
    Test speed at speedtest.net
    Mumbai server and say Sydney server.
    ( each test will use about 10 to 15 MB data )
    compare for whichever modem you used.

    If all appear Ok no need for tests. confirm.
    -

  16. #16
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Does that downstream and upstream rate on the router status page indicate the current Internet speed??

    Do u want me to test the speed using both Mumbai Server and Sydney servers using both linksys and Huwaie routers? I was facing problems with the speed test on speedtest.net, was getting latency check error every time. If I try 5 times I am successful one time. Any workarounds?? please suggest.

    Currently at work cannot test. Will post the results once I get back to home. Sorry for inconvenience...
    Last edited by mvenkat_2000; 12th May 2009 at 07:54 PM.

  17. #17
    LEARNER
    Join Date
    Aug 2007
    Posts
    15,263

    Default

    Does that downstream and upstream rate on the router status page indicate the current Internet speed?
    NO. Shows the MAX speed , what the modem is tuned up for.

    No problem. Speed test is not necessary.
    if all are normal,
    observe set up for a week and
    give feedback.

    Para two ;
    The speed results are not always same and tend to vary.
    from web site to website/ servers.
    Standard considered most reliable : Microsoft sites.

    Just to get an idea of the /Line /system/modem settings.
    we test at speedtest.net and also at speedguide.net.
    results will vary according to distance /server selected , your system/s settings etc.

  18. #18
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Thanks for the guidance provided so far. I shifted the router location yesterday to a different place and noticed that there was an improvement in the internet speed. Will observe for a week and post the results.

  19. #19
    Junior Member
    Join Date
    May 2009
    Posts
    9

    Default

    Noticed that the speed was pretty ok and stable after I changed the location of my router. But now I see another problem. My laptop doesnt get the IP address first time when i start the laptop. I had to do a Repair action to get the IP address allocated. what could be the reason?

    Also, do you have any suggestions for fine tuning the router further.

    Thanks very much for all the support.

Similar Threads

  1. Issues with Linksys WAG120N .
    By surfer in forum BSNL broadband
    Replies: 3
    Last Post: 15th November 2011, 07:47 AM
  2. BSNL TYPE II modem possible speed issues?
    By sumang24 in forum BSNL broadband
    Replies: 6
    Last Post: 9th December 2010, 09:33 PM
  3. Replies: 0
    Last Post: 23rd September 2009, 09:30 PM
  4. Replies: 2
    Last Post: 21st July 2008, 03:26 PM
  5. Replies: 0
    Last Post: 7th August 2007, 11:09 AM